2022.1.28 라이트세일 인스턴스 업데이트 기록

By | 2022-01-28

연말에 업데이트 했는데 한달도 안되어 다시 업데이트를 했다. 그저께 Let’s Encrypt로부터 아래와 같은 메일이 왔는데.

Please immediately renew your TLS certificate(s) that were issued from
Let’s Encrypt using the TLS-ALPN-01 validation method and the following
ACME registration (account) ID(s):

https 접속을 위해 Let’s Encrypt 인증서를 설치하긴 했지만 “TLS-ALPN-01 validation method”에 해당하는지 여부는 모르겠다. 뭐 인증서 갱신하면 되겠지, 싶었는데 인증서 갱신 방법으로 많이 소개된 Certbot 을 이용하려 했으나 설치가 되어 있지 않았다. (또는 찾지 못하겠거나.)

bncert-tool 로 갱신되나 해봤더니 이미 키가 있으니 기존 키를 사용한다고 하고. 기존키를 수동으로 삭제하자니 아파치 설정도 수정해야 한다고 하여. 오히려 잘됐다 (링크 삭제됨. 하단 주석 참고) 싶어 인스턴스 새로 생성하고 워드프레스 복원하고 인증서 새로 받는 방법을 택했다.

리눅스 배포판ApachePHPDB
2019.12우분투 16.04.72.4.397.3.7MySQL 8.0.17
2021.2데비안 102.4.467.4.13MySQL 8.0.22
2021.122.4.517.4.25MariaDB 10.3.32
2022.12.4.527.4.27

[업데이트]@2022.2.2
본문중에 “오히려 잘됐다”는 링크는 원래 트위터로 향하는 링크였는데 지금은 계정 자체가 지워져버렸다. 다행이 당시 메신저로 공유했던 내용이 남아 있어 내용을 적어둔다. ‘스트레스 덜 받는 마법의 말투 1. 오히려 좋아 2. 그럴 수도 있지 3. 가보자고’

Leave a Reply

Your email address will not be published.