워드프레스 1.5x 일부 파일 패치 필요

워드프레스 1.5x버젼을 사용하실 경우 외부의 공격위험이 있는 파일에 대한 수정이 필요합니다. ( Security Update – 2005년 5월27일- )
순서는 아래와 같습니다.

  1. 워드프레스가 설치된 디렉토리 아래
    wp-includes/template-functions-category.php 파일을 엽니다.
  2. 103번째 줄 근처에서 function get_the_category_by_ID($cat_ID) { 를 찾아 그 바로 아랫줄에
  3. $cat_ID = (int) $cat_ID; 라는 줄을 추가시킵니다.

그림으로 보면 아래와 같습니다. 노란줄로 표시된 104번째 줄을 새로 추가해야 합니다.

5월27일 이후 배포되는 1.5.1.2 버젼부터는 이 부분이 수정되어 배포되고 있습니다. 웹호스팅 서버에 mod_security 모듈이 설치되어 있는 경우에는 공격의 위험을 피할 수 있으나 설치되지 않은 곳이 많을것으로 예상합니다.

One Reply to “워드프레스 1.5x 일부 파일 패치 필요”

Comments are closed.